GSXR k5 600 wont start due to alarm system

Joeeyireland

New member
Jan 5, 2020
10
8
3
Lincolnshire
Hi guys I have a k5 600 and when I brought it, it came with an alarm which beeps once to disarm and twice when armed also when I turn the ignition on if the button is not pressed I can’t start the bike until I do so and it makes a noise like the fuel pump is priming.

today I went to turn it on and the alarm came on and the sound went really quiet, now when I turn it on and press the button I can’t start the bike and I don’t hear the priming noise.

I thought it was a dead battery so I’ve had it on charge tonight but still no luck. The check light is on aswell if that helps but if I don’t disarm it with the ignition on the light always came on

anybody have any ideas at all, I couldn’t tell you what the alarm is until tomorrow morning
 

Joeeyireland

New member
Jan 5, 2020
10
8
3
Lincolnshire
So looking into this further we narrowed it down to the Meta Alarm Box’s battery is dying as the siren does not sound as Loud as it normally does. I am currently taking it out and putting the loom back to standard. Does anybody know any good budget alarm systems or trackers?
 

Joeeyireland

New member
Jan 5, 2020
10
8
3
Lincolnshire
Hey,

Yeah It turns out there was a Hidden 15Amp Fuse that I did not see and has blown, also the internal battery is dying inside the Meta System 2 Box itself so instead of paying for a second hand one as I believe they hard to get hold of. I am going to remove it all from the wiring loom and replace either with a Tracker or another newer alarm system.
 
  • Like
Reactions: GixxerGod

Server Costs

Total amount
$25.00
Goal
$30.00

Advertisment